// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)The\sfirst\svalue\sis (?<from>[^\s]+).+(?<to>\d)").unwrap();
let string = "The first value is 0.00 and The second value is 0\",\"origin\":\"rep\",\"source_instance\":\"0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}