using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]+ ?([0-9]+ ?\-?[a-z]{0,2})";
string input = @"1st street 25
1st street 25 a
1st street 25b
1st street 25-ab";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}