package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z]+ ?([0-9]+ ?\-?[a-z]{0,2})`)
var str = `1st street 25
1st street 25 a
1st street 25b
1st street 25-ab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}