re = /[a-z]+ ?([0-9]+ ?\-?[a-z]{0,2})/i
str = '1st street 25
1st street 25 a
1st street 25b
1st street 25-ab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end