// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[a-z]+ ?([0-9]+ ?\-?[a-z]{0,2})").unwrap();
let string = "1st street 25
1st street 25 a
1st street 25b
1st street 25-ab";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}