using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(c:\\)\\?(temp)(?!.*\.\.).{0,200}$";
string input = @"c:\temp\hello\world.txt
c:\temp\..\Windows\world.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}