const regex = /^(c:\\)\\?(temp)(?!.*\.\.).{0,200}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(c:\\\\)\\\\?(temp)(?!.*\\.\\.).{0,200}$', 'gm')
const str = `c:\\temp\\hello\\world.txt
c:\\temp\\..\\Windows\\world.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}