$re = '/^(c:\\\\)\\\\?(temp)(?!.*\.\.).{0,200}$/m';
$str = 'c:\\temp\\hello\\world.txt
c:\\temp\\..\\Windows\\world.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);