re = /^(c:\\)\\?(temp)(?!.*\.\.).{0,200}$/m
str = 'c:\\temp\\hello\\world.txt
c:\\temp\\..\\Windows\\world.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end