import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!<[^>]*)|(?![^<]*>))((?<=^|\\W)(a))";
final String string = "Match all words starting with \"a\" not in a tag <a>a>a<a>a</a> text: a 1<2 but fails to match a in here 4>3 a <a a<a>a><a";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}