$re = '/((?<!<[^>]*)|(?![^<]*>))((?<=^|\W)(a))/';
$str = 'Match all words starting with "a" not in a tag <a>a>a<a>a</a> text: a 1<2 but fails to match a in here 4>3 a <a a<a>a><a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);