re = /((?<!<[^>]*)|(?![^<]*>))((?<=^|\W)(a))/
str = 'Match all words starting with "a" not in a tag <a>a>a<a>a</a> text: a 1<2 but fails to match a in here 4>3 a <a a<a>a><a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end