const regex = /((?<!<[^>]*)|(?![^<]*>))((?<=^|\W)(a))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!<[^>]*)|(?![^<]*>))((?<=^|\\W)(a))', 'g')
const str = `Match all words starting with "a" not in a tag <a>a>a<a>a</a> text: a 1<2 but fails to match a in here 4>3 a <a a<a>a><a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}