#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!TITUSVILLE|HOLLIDAYSBURG)\sWD\s"
Local $sString = "PA CRAWFORD MEADVILLE WD 02" & @CRLF & _
"PA CRAWFORD TITUSVILLE WD 0" & @CRLF & _
"PA BLAIR HOLLIDAYSBURG WD 01" & @CRLF & _
"PA BLAIR ALTOONA WD 03"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")