using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!TITUSVILLE|HOLLIDAYSBURG)\sWD\s";
string input = @"PA CRAWFORD MEADVILLE WD 02
PA CRAWFORD TITUSVILLE WD 0
PA BLAIR HOLLIDAYSBURG WD 01
PA BLAIR ALTOONA WD 03";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}