$re = '/(?<!TITUSVILLE|HOLLIDAYSBURG)\sWD\s/m';
$str = 'PA CRAWFORD MEADVILLE WD 02
PA CRAWFORD TITUSVILLE WD 0
PA BLAIR HOLLIDAYSBURG WD 01
PA BLAIR ALTOONA WD 03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);