re = /(?<!TITUSVILLE|HOLLIDAYSBURG)\sWD\s/m
str = 'PA CRAWFORD MEADVILLE WD 02
PA CRAWFORD TITUSVILLE WD 0
PA BLAIR HOLLIDAYSBURG WD 01
PA BLAIR ALTOONA WD 03'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end