using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{069a89e2ffae2a55a70371e5cc477573:(.*)?([|].*):069a89e2ffae2a55a70371e5cc477573}";
string input = @"{069a89e2ffae2a55a70371e5cc477573:NAME|s=1;d=2:069a89e2ffae2a55a70371e5cc477573}
{069a89e2ffae2a55a70371e5cc477573:NAME2:069a89e2ffae2a55a70371e5cc477573}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}