re = /{069a89e2ffae2a55a70371e5cc477573:(.*)?([|].*):069a89e2ffae2a55a70371e5cc477573}/
str = '{069a89e2ffae2a55a70371e5cc477573:NAME|s=1;d=2:069a89e2ffae2a55a70371e5cc477573}
{069a89e2ffae2a55a70371e5cc477573:NAME2:069a89e2ffae2a55a70371e5cc477573}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end