$re = '/{069a89e2ffae2a55a70371e5cc477573:(.*)?([|].*):069a89e2ffae2a55a70371e5cc477573}/';
$str = '{069a89e2ffae2a55a70371e5cc477573:NAME|s=1;d=2:069a89e2ffae2a55a70371e5cc477573}
{069a89e2ffae2a55a70371e5cc477573:NAME2:069a89e2ffae2a55a70371e5cc477573}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);