import Foundation
let pattern = #"{069a89e2ffae2a55a70371e5cc477573:(.*)?([|].*):069a89e2ffae2a55a70371e5cc477573}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{069a89e2ffae2a55a70371e5cc477573:NAME|s=1;d=2:069a89e2ffae2a55a70371e5cc477573}
{069a89e2ffae2a55a70371e5cc477573:NAME2:069a89e2ffae2a55a70371e5cc477573}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)