#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ContactMessageTransport[\s\S]*?Started(?:[^\r\n]*[\r\n]){3}"
Local $sString = " <getAllMessageQueueInfoResponse xmlns="http:abcd.com/MessageQueueAnalyticsAPI">" & @CRLF & _
" <return>" & @CRLF & _
" <Entry xmlns:pogo="http://example.com/com/integration/services/messagequeueanalyticsservice">" & @CRLF & _
" <pogo:AckCount>0</pogo:AckCount>" & @CRLF & _
" <pogo:DestinationID>0</pogo:DestinationID>" & @CRLF & _
" <pogo:ErrorCount>25</pogo:ErrorCount>" & @CRLF & _
" <pogo:ID>67</pogo:ID>" & @CRLF & _
" <pogo:Latest>2017-11-28T00:00:00-05:00</pogo:Latest>" & @CRLF & _
" <pogo:Name>ContactMessageTransport</pogo:Name>" & @CRLF & _
" <pogo:NotAckCount>0</pogo:NotAckCount>" & @CRLF & _
" <pogo:Oldest>2017-11-28T00:00:00-05:00</pogo:Oldest>" & @CRLF & _
" <pogo:RetryableErrorCount>31</pogo:RetryableErrorCount>" & @CRLF & _
" <pogo:SkippedCount>0</pogo:SkippedCount>" & @CRLF & _
" <pogo:Status>Started</pogo:Status>" & @CRLF & _
" <pogo:UnsentCount>212</pogo:UnsentCount>" & @CRLF & _
" </Entry>" & @CRLF & _
" <Entry xmlns:pogo="http://example.com/com/integration/services/messagequeueanalyticsservice">" & @CRLF & _
" <pogo:AckCount>0</pogo:AckCount>" & @CRLF & _
" <pogo:DestinationID>0</pogo:DestinationID>" & @CRLF & _
" <pogo:ErrorCount>0</pogo:ErrorCount>" & @CRLF & _
" <pogo:ID>65</pogo:ID>" & @CRLF & _
" <pogo:Latest>2018-03-17T00:00:00-04:00</pogo:Latest>" & @CRLF & _
" <pogo:Name>Email</pogo:Name>" & @CRLF & _
" <pogo:NotAckCount>0</pogo:NotAckCount>" & @CRLF & _
" <pogo:Oldest>2018-03-17T00:00:00-04:00</pogo:Oldest>" & @CRLF & _
" <pogo:RetryableErrorCount>4</pogo:RetryableErrorCount>" & @CRLF & _
" <pogo:SkippedCount>0</pogo:SkippedCount>" & @CRLF & _
" <pogo:Status>Started</pogo:Status>" & @CRLF & _
" <pogo:UnsentCount>0</pogo:UnsentCount>" & @CRLF & _
" </Entry>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")