// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ContactMessageTransport[\s\S]*?Started(?:[^\r\n]*[\r\n]){3}").unwrap();
let string = " <getAllMessageQueueInfoResponse xmlns=\"http:abcd.com/MessageQueueAnalyticsAPI\">
<return>
<Entry xmlns:pogo=\"http://example.com/com/integration/services/messagequeueanalyticsservice\">
<pogo:AckCount>0</pogo:AckCount>
<pogo:DestinationID>0</pogo:DestinationID>
<pogo:ErrorCount>25</pogo:ErrorCount>
<pogo:ID>67</pogo:ID>
<pogo:Latest>2017-11-28T00:00:00-05:00</pogo:Latest>
<pogo:Name>ContactMessageTransport</pogo:Name>
<pogo:NotAckCount>0</pogo:NotAckCount>
<pogo:Oldest>2017-11-28T00:00:00-05:00</pogo:Oldest>
<pogo:RetryableErrorCount>31</pogo:RetryableErrorCount>
<pogo:SkippedCount>0</pogo:SkippedCount>
<pogo:Status>Started</pogo:Status>
<pogo:UnsentCount>212</pogo:UnsentCount>
</Entry>
<Entry xmlns:pogo=\"http://example.com/com/integration/services/messagequeueanalyticsservice\">
<pogo:AckCount>0</pogo:AckCount>
<pogo:DestinationID>0</pogo:DestinationID>
<pogo:ErrorCount>0</pogo:ErrorCount>
<pogo:ID>65</pogo:ID>
<pogo:Latest>2018-03-17T00:00:00-04:00</pogo:Latest>
<pogo:Name>Email</pogo:Name>
<pogo:NotAckCount>0</pogo:NotAckCount>
<pogo:Oldest>2018-03-17T00:00:00-04:00</pogo:Oldest>
<pogo:RetryableErrorCount>4</pogo:RetryableErrorCount>
<pogo:SkippedCount>0</pogo:SkippedCount>
<pogo:Status>Started</pogo:Status>
<pogo:UnsentCount>0</pogo:UnsentCount>
</Entry>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}