use strict;
my $str = ' <getAllMessageQueueInfoResponse xmlns="http:abcd.com/MessageQueueAnalyticsAPI">
<return>
<Entry xmlns:pogo="http://example.com/com/integration/services/messagequeueanalyticsservice">
<pogo:AckCount>0</pogo:AckCount>
<pogo:DestinationID>0</pogo:DestinationID>
<pogo:ErrorCount>25</pogo:ErrorCount>
<pogo:ID>67</pogo:ID>
<pogo:Latest>2017-11-28T00:00:00-05:00</pogo:Latest>
<pogo:Name>ContactMessageTransport</pogo:Name>
<pogo:NotAckCount>0</pogo:NotAckCount>
<pogo:Oldest>2017-11-28T00:00:00-05:00</pogo:Oldest>
<pogo:RetryableErrorCount>31</pogo:RetryableErrorCount>
<pogo:SkippedCount>0</pogo:SkippedCount>
<pogo:Status>Started</pogo:Status>
<pogo:UnsentCount>212</pogo:UnsentCount>
</Entry>
<Entry xmlns:pogo="http://example.com/com/integration/services/messagequeueanalyticsservice">
<pogo:AckCount>0</pogo:AckCount>
<pogo:DestinationID>0</pogo:DestinationID>
<pogo:ErrorCount>0</pogo:ErrorCount>
<pogo:ID>65</pogo:ID>
<pogo:Latest>2018-03-17T00:00:00-04:00</pogo:Latest>
<pogo:Name>Email</pogo:Name>
<pogo:NotAckCount>0</pogo:NotAckCount>
<pogo:Oldest>2018-03-17T00:00:00-04:00</pogo:Oldest>
<pogo:RetryableErrorCount>4</pogo:RetryableErrorCount>
<pogo:SkippedCount>0</pogo:SkippedCount>
<pogo:Status>Started</pogo:Status>
<pogo:UnsentCount>0</pogo:UnsentCount>
</Entry>';
my $regex = qr/ContactMessageTransport[\s\S]*?Started(?:[^\r\n]*[\r\n]){3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}