# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ContactMessageTransport[\s\S]*?Started(?:[^\r\n]*[\r\n]){3}"
test_str = (" <getAllMessageQueueInfoResponse xmlns=\"http:abcd.com/MessageQueueAnalyticsAPI\">\n"
" <return>\n"
" <Entry xmlns:pogo=\"http://example.com/com/integration/services/messagequeueanalyticsservice\">\n"
" <pogo:AckCount>0</pogo:AckCount>\n"
" <pogo:DestinationID>0</pogo:DestinationID>\n"
" <pogo:ErrorCount>25</pogo:ErrorCount>\n"
" <pogo:ID>67</pogo:ID>\n"
" <pogo:Latest>2017-11-28T00:00:00-05:00</pogo:Latest>\n"
" <pogo:Name>ContactMessageTransport</pogo:Name>\n"
" <pogo:NotAckCount>0</pogo:NotAckCount>\n"
" <pogo:Oldest>2017-11-28T00:00:00-05:00</pogo:Oldest>\n"
" <pogo:RetryableErrorCount>31</pogo:RetryableErrorCount>\n"
" <pogo:SkippedCount>0</pogo:SkippedCount>\n"
" <pogo:Status>Started</pogo:Status>\n"
" <pogo:UnsentCount>212</pogo:UnsentCount>\n"
" </Entry>\n"
" <Entry xmlns:pogo=\"http://example.com/com/integration/services/messagequeueanalyticsservice\">\n"
" <pogo:AckCount>0</pogo:AckCount>\n"
" <pogo:DestinationID>0</pogo:DestinationID>\n"
" <pogo:ErrorCount>0</pogo:ErrorCount>\n"
" <pogo:ID>65</pogo:ID>\n"
" <pogo:Latest>2018-03-17T00:00:00-04:00</pogo:Latest>\n"
" <pogo:Name>Email</pogo:Name>\n"
" <pogo:NotAckCount>0</pogo:NotAckCount>\n"
" <pogo:Oldest>2018-03-17T00:00:00-04:00</pogo:Oldest>\n"
" <pogo:RetryableErrorCount>4</pogo:RetryableErrorCount>\n"
" <pogo:SkippedCount>0</pogo:SkippedCount>\n"
" <pogo:Status>Started</pogo:Status>\n"
" <pogo:UnsentCount>0</pogo:UnsentCount>\n"
" </Entry>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.