#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*{4,}((?:\r?\n(?!\s*$|\*{4}).+)*)"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit." & @CRLF & _
"" & @CRLF & _
"****" & @CRLF & _
"Sed id placerat magna." & @CRLF & _
"" & @CRLF & _
"*******" & @CRLF & _
"Pellentesque in ex ac urna tincidunt tristique. " & @CRLF & _
"*******" & @CRLF & _
"Pellentesque in ex ac urna tincidunt tristique. " & @CRLF & _
"Etiam dapibus faucibus gravida." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*******" & @CRLF & _
"Pellentesque in ex ac urna tincidunt tristique. " & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")