$re = '/^\*{4,}((?:\r?\n(?!\s*$|\*{4}).+)*)/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit.
****
Sed id placerat magna.
*******
Pellentesque in ex ac urna tincidunt tristique.
*******
Pellentesque in ex ac urna tincidunt tristique.
Etiam dapibus faucibus gravida.
*******
Pellentesque in ex ac urna tincidunt tristique.
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);