import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*{4,}((?:\\r?\\n(?!\\s*$|\\*{4}).+)*)";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n\n"
+ "****\n"
+ "Sed id placerat magna.\n\n"
+ "*******\n"
+ "Pellentesque in ex ac urna tincidunt tristique. \n"
+ "*******\n"
+ "Pellentesque in ex ac urna tincidunt tristique. \n"
+ "Etiam dapibus faucibus gravida.\n\n\n"
+ "*******\n"
+ "Pellentesque in ex ac urna tincidunt tristique. \n"
+ "test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}