re = /^\*{4,}((?:\r?\n(?!\s*$|\*{4}).+)*)/m
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit.
****
Sed id placerat magna.
*******
Pellentesque in ex ac urna tincidunt tristique.
*******
Pellentesque in ex ac urna tincidunt tristique.
Etiam dapibus faucibus gravida.
*******
Pellentesque in ex ac urna tincidunt tristique.
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end