using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-4]($|\.)|5.[0-1]|^5.2($|\.([0-9]$|1[0-9]|2[0-7])$)";
string input = @"5.2
5.2.28
5.2.27
4
4.
40
10
1.
1
6.0
5.2.2
5.5.6
5.2.6
5.2
5.2.1
5.2.28
5.2.8
5.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}