use strict;
my $str = '5.2
5.2.28
5.2.27
4
4.
40
10
1.
1
6.0
5.2.2
5.5.6
5.2.6
5.2
5.2.1
5.2.28
5.2.8
5.1';
my $regex = qr/^[0-4]($|\.)|5.[0-1]|^5.2($|\.([0-9]$|1[0-9]|2[0-7])$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}