const regex = /^[0-4]($|\.)|5.[0-1]|^5.2($|\.([0-9]$|1[0-9]|2[0-7])$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-4]($|\\.)|5.[0-1]|^5.2($|\\.([0-9]$|1[0-9]|2[0-7])$)', 'gm')
const str = `5.2
5.2.28
5.2.27
4
4.
40
10
1.
1
6.0
5.2.2
5.5.6
5.2.6
5.2
5.2.1
5.2.28
5.2.8
5.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}