$re = '/^[0-4]($|\.)|5.[0-1]|^5.2($|\.([0-9]$|1[0-9]|2[0-7])$)/m';
$str = '5.2
5.2.28
5.2.27
4
4.
40
10
1.
1
6.0
5.2.2
5.5.6
5.2.6
5.2
5.2.1
5.2.28
5.2.8
5.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);