using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>\s*(<a[^>]*>)?(<img[^>]+>)(<\/a>)?\s*<\/p>";
string substitution = @"\1\2\3";
string input = @"<html>
<p><a href=""><img src="" /></a></p>
<p><img src="" /></p>
</html>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}