$re = '/<p>\s*(<a[^>]*>)?(<img[^>]+>)(<\/a>)?\s*<\/p>/im';
$str = '<html>
<p><a href=""><img src="" /></a></p>
<p><img src="" /></p>
</html>';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;