package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<p>\s*(<a[^>]*>)?(<img[^>]+>)(<\/a>)?\s*<\/p>`)
var str = `<html>
<p><a href=""><img src="" /></a></p>
<p><img src="" /></p>
</html>`
var substitution = "\1\2\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}