const regex = /<p>\s*(<a[^>]*>)?(<img[^>]+>)(<\/a>)?\s*<\/p>/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>\\s*(<a[^>]*>)?(<img[^>]+>)(<\\\/a>)?\\s*<\\\/p>', 'igm')
const str = `<html>
<p><a href=""><img src="" /></a></p>
<p><img src="" /></p>
</html>`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);