$re = '/(?<one>M\/S\s(\w+?\s)+(?<two>(U22334)))/i';
$str = 'M/S ALPHA DAILY LIVING PRODUCTS INDIA PRIVATE LIMITED U22334';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);