re = /(?<one>M\/S\s(\w+?\s)+(?<two>(U22334)))/i
str = 'M/S ALPHA DAILY LIVING PRODUCTS INDIA PRIVATE LIMITED U22334'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end