using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(#+) .*\[\[Wikilink\]\].*$(?=([\S\s]*?)(?:^(?!\1#+)#+ |\z))";
string input = @"# Part 1
## Some title 1 [[Wikilink]]
Some
random
content
### Sub title 1
Content
### Sub item 2
Content
## Other title 2
Content
# Part 2
## title
### Sub item [[Wikilink]]
content here
## title
# Part 3 [[Wikilink]]
content";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}