use strict;
my $str = '# Part 1
## Some title 1 [[Wikilink]]
Some
random
content
### Sub title 1
Content
### Sub item 2
Content
## Other title 2
Content
# Part 2
## title
### Sub item [[Wikilink]]
content here
## title
# Part 3 [[Wikilink]]
content';
my $regex = qr/^(#+) .*\[\[Wikilink\]\].*$(?=([\S\s]*?)(?:^(?!\1#+)#+ |\z))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}