re = /^(#+) .*\[\[Wikilink\]\].*$(?=([\S\s]*?)(?:^(?!\1#+)#+ |\z))/m
str = '# Part 1
## Some title 1 [[Wikilink]]
Some
random
content
### Sub title 1
Content
### Sub item 2
Content
## Other title 2
Content
# Part 2
## title
### Sub item [[Wikilink]]
content here
## title
# Part 3 [[Wikilink]]
content'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end