import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#+) .*\\[\\[Wikilink\\]\\].*$(?=([\\S\\s]*?)(?:^(?!\\1#+)#+ |\\z))";
final String string = "# Part 1\n\n"
+ "## Some title 1 [[Wikilink]]\n\n"
+ "Some\n"
+ "random\n"
+ "content\n\n"
+ "### Sub title 1\n\n"
+ "Content\n\n"
+ "### Sub item 2\n\n"
+ "Content\n\n"
+ "## Other title 2\n\n"
+ "Content\n\n"
+ "# Part 2\n\n"
+ "## title \n\n"
+ "### Sub item [[Wikilink]]\n\n"
+ "content here\n\n"
+ "## title\n\n"
+ "# Part 3 [[Wikilink]]\n\n"
+ "content";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}