package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+?:){4}(\d+)`)
var str = `arn:aws:ec2:eu-abcd-1:123456789:instance/i-000000000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}