$re = '/(\S+?:){4}(\d+)/m';
$str = 'arn:aws:ec2:eu-abcd-1:123456789:instance/i-000000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);