const regex = /(\S+?:){4}(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+?:){4}(\\d+)', 'gm')
const str = `arn:aws:ec2:eu-abcd-1:123456789:instance/i-000000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}