re = /(\S+?:){4}(\d+)/m
str = 'arn:aws:ec2:eu-abcd-1:123456789:instance/i-000000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end