using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.[^{\s]*(?=\s*{)";
string substitution = @".a";
string input = @".text-center { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}