import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.[^\\{\\s]*(?=\\s*\\{)";
final String string = ".text-center { text-align: center; }\n"
+ "table.simple{background:#fff;}.bg-white{background:#fff;}\n"
+ "/*# sourceMappingURL=style.css.map */\n"
+ "/*\n"
+ "Example comment file.css\n"
+ "*/";
final String subst = ".a";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}