use strict;
my $str = '.text-center { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/';
my $regex = qr/\.[^{\s]*(?=\s*{)/p;
my $subst = '.a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";